procv exemplos

Download PROCV  EXEMPLOS

Post on 25-Jun-2015

4.274 views

Category:

Documents

4 download

Embed Size (px)

TRANSCRIPT

PROCV 01 EXEMPLO

Voc criou uma planilha (Cadastro) com os dados dos alunos da sua escola.

Em outra planilha (Notas), sero lanadas as avaliaes destes alunos. Em Notas, voc quer digitar a matricula e...

... deixar para o Excel a responsabilidade de pesquisar e retornar o nome do aluno,

armazenado em Cadastro.

Vou utilizar como exemplo uma planilha com poucos dados. Mas o que for utilizado

para o pequeno intervalo de clulas ( A2:B7 ) pode ser aplicado em qualquer quantidade de linhas e colunas. Adapte o exemplo s suas necessidades, ok ?

Para aprender como criar a pesquisa automtica dos nomes, acompanhe este Ative a planilha Notas. Em B:2, digite o sinal de igual ( = ).

exerccio.

Eu no gosto de digitar a frmula diretamente na clula. questo de gosto. Por

isso, se quiser me acompanhar, clique na barra de frmulas.

Digite o nome da funo: =PROCV(.

o valor que ser pesquisado. Neste exemplo, a matricula digitada na clula. Portanto, clique em A:2.

Digite ponto e vrgula ( ; ).

o intervalo de clulas, a tabela, na qual ser feita a pesquisa. Neste exemplo,

informe o nome da planilha ( Cadastro ) seguido do smbolo de exclamao ( ! ) mais o intervalo de clulas ( A2:B7 ). A sintaxe : =PROCV(A2;Cadastro!A2:B7.

Digite outro ponto e vrgula ( ; ).

a posio da coluna, no intervalo, onde est o nome. Neste caso, 2 equivale

coluna B.

Digite outro ponto e vrgula ( ; ) para informar o ltimo parmetro.

Defina-o como FALSO.

Quando o quarto parmetro definido como FALSO, o Excel XP ir pesquisar o

valor exato. Ou seja, se voc digitar a matrcula 5, PROCV ir pesquisar pelo nmero 5. Se no encontr-lo, ir retornar uma mensagem de erro. Por outro lado, informando VERDADEIRO, se o nmero digitado no for encontrado, Para finalizar, feche a funo com ) e tecle [ Enter ]. a pesquisa ir procurar pelo nmero aproximado. No o nosso caso.

Sim, jovem, tens razo. Concordo. Precisamos verificar se a matrcula foi digitada, para s ento efetuar a pesquisa. Clique em A:2.

Mas, vamos, primeiro, verificar se a pesquisa feita corretamente.

Digite uma matrcula vlida e tecle [ Enter ].

O Excel XP ir retornar, corretamente, o nome do aluno. No prximo captulo, vamos aprimorar a nossa planilha, ok ? A pesquisa somente

ser feita se a matrcula for digitada na coluna A.

PESQUISAR NOMES Clique em B:2.

Clique entre o sinal de igual ( = ) e PROCV.

Comece alterando a sintaxe: =SE(.

sintaxe

A condio para a pesquisa que algum valor seja digitado em A:2. Ento, a ficar No bom e sarado Portugus: se A:2 for maior do que zero,... assim:

=SE(A2>0;PROCV(...

E SE A:2 NO FOR MAIOR DO QUE ZERO ? Voc precisa, ento, informar ao software microsoftiano o que fazer. Clique direita da frmula.

Digite ponto e vrgula ( ; ).

E complete com " ").

A sintaxe ficar assim: =SE(A2>O;PROCV(A2;Cadastro!A2:B7;2;FALSO);""). Para finalizar, tecle [ Enter ].

Clique em A:2 e...

... pressione [ Delete ]. Observe: a pesquisa no foi feita e nenhum erro foi retornado.

Selecione B:2.

Posicione o ponteiro na ala de preenchimento e arraste-a para baixo.

Sim, jovem, voc visualizou o erro. Parabns. Ao copiar a frmula, o intervalo ( A2:B7 ) alterado. Isto no pode acontecer. Voc

precisa informar ao Excel XP que mantenha fixo Cadastro!A2:B7.

Selecione B:2 e...

... insira o smbolo $ entre A2 e B7.

A

sintaxe

dever

ficar

assim:

=SE(A2>O;PROCV(A2;Cadastro!

A$2:B$7;2;FALSO);""). Agora, voc pode copi-la.

A:2,...

O primeiro parmetro, a clula que ser utilizada para pesquisa, nesse exemplo,

... ser atualizada quando voc arrastar e copiar a frmula. Isto est correto.

Porm, o intervalo que ser pesquisado, Cadastro!A$2:B$7, ser preservado.