Linguagem C Estruturas de Seleo. Estrutura de um Programa em C Tudo em um arquivo.c /*Funes*/ Tipo funo1 (declarao de parmetros){ /*declaraes.

Download Linguagem C Estruturas de Seleo. Estrutura de um Programa em C Tudo em um arquivo.c /*Funes*/ Tipo funo1 (declarao de parmetros){ /*declaraes.

Post on 17-Apr-2015

134 views

Category:

Documents

0 download

TRANSCRIPT

  • Slide 1
  • Linguagem C Estruturas de Seleo
  • Slide 2
  • Estrutura de um Programa em C Tudo em um arquivo.c /*Funes*/ Tipo funo1 (declarao de parmetros){ /*declaraes locais;*/ /*comandos;*/ } /* Funo principal marca o incio da execuo do programa*/ int main( ) { declaraes locais; comandos;.... } /*Declaraes Globais*/ /*Prottipos de Funes*/ /*Diretivas de Pr-processamento*/ #include.... #define....
  • Slide 3
  • Incio /*Calculo do permetro e a rea de uma circunferncia*/ inteiro R; real Perm, Area, PI; PI 3.14159; Escreva(Valor do raio:); Leia(R); Perm 2 * PI * R; Area PI*R**2; Escreva(Permetro:); Escreva(R); Escreva(rea: ) Escreva(Area); Fim; #include int main(void){ int R; float Perm, Area, PI; PI = 3.14159; printf(Entre com o valor do raio:); scanf( %d,&R); Perm = 2 * PI * R; Area = PI* pow(R,2); printf(Permetro: %.2f\n,Perm); printf(rea: %.2f\n,Area); } Traduo Portugol para C
  • Slide 4
  • Funes de Entrada/Sada A funo printf: Sintaxe da chamada printf("expresso de controle", lista de argumentos); Expresso de controle caracteres impressos na tela + cd. de formatao dos argumentos; Lista de argumentos: expresses, variveis ou constantes; Exemplo : Algoritmo: Escreva("O valor da varivel "); Escreva(Y); Em C: printf("O valor da varivel %d\n", Y ); /*se Y int*/ ou printf("O valor da varivel %f\n", Y ); /*se Y float*/
  • Slide 5
  • Funes de Entrada/Sada A funo scanf Sintaxe da chamada scanf("expresso de controle", lista de argumentos); Expresso de controle: caracteres lidos do teclado + cd. de formatao dos argumentos Lista de argumentos: endereos das variveis a serem lidas Operador de Endereo &: Exemplo : &Nfilhos Exemplo: Algoritmo: leia(A,B ); Em C: scanf("%d %d,&A, &B); /*se A e B so int */ ou scanf("%f %f,&A, &B); /*se A e B so float */
  • Slide 6
  • Estrutura de Seleo Estrutura de seleo se (condio for Verdade) ento //comando1; /*ou bloco de comandos;*/ fim_se; if (condio != 0) //no vai ; { //comando1; /*ou bloco de comandos;*/ }
  • Slide 7
  • Estrutura de Seleo Exemplo #include int main() { int a; //Declarao de varivel printf(Digite um nmero:\n); scanf(%d,&a); if (a > 10) //no vai ; { printf(O numero maior que 10\n); } printf(Fim\n); }
  • Slide 8
  • Estrutura de Seleo Estrutura de seleo composta se (condio for Verdade) ento comando1; {ou bloco de comandos}; seno comando1; {ou bloco de comandos}; fim_se; if (condio != 0) //no vai ; { comando1; {ou bloco de comandos}; } else //no vai ; { comando1; {ou bloco de comandos}; } 10) //no vai ; {">
  • Estrutura de Seleo Exemplo #include int main(){ int a; //Declarao de varivel printf(Digite um nmero:\n); scanf(%d,&a); if (a > 10) //no vai ; { printf(O numero maior que 10\n); } else //no vai ; { printf(O nmero menor ou igual a 10\n); } printf(Fim\n); }
  • Slide 10
  • Estrutura de Seleo Estrutura de seleo encadeada se (condio1 for Verdade) ento se (condio2 for Verdade) ento se (condio3 for Verdade) ento //comando1; /*ou bloco de comandos*/ fim_se; if (condio1 != 0) //no vai ; { if (condio2 != 0) //no vai ; { if (condio3 != 0) //no vai ; { //comando1 /*ou bloco de comandos*/ }
  • Slide 11
  • Exemplo #include int main(){ int a; //Declarao de varivel printf(Digite um nmero:\n); scanf(%d,&a); if (a > 10) //no vai ; { if (a < 20) //no vai ; { if ((a % 2) == 0) //no vai ; { printf(O numero maior que 10, menor que 20 e par\n); } printf(Fim\n); }
  • Slide 12
  • Estrutura de Seleo Estrutura de seleo encadeada composta se (condio1 for Verdade) ento se (condio2 for Verdade) ento se (condio3 for Verdade) ento /*bloco de comandos*/ seno /*bloco de comandos*/ fim_se; //condio 3 fim_se; //condio 2 seno /*bloco de comandos*/ fim_se; //condio 1 if (condio1 != 0) //no vai ; { if (condio2 != 0) //no vai ; { if (condio3 != 0) //no vai ; { /*bloco de comandos*/ } else { /*bloco de comandos*/ } else { /*bloco de comandos*/ }
  • Slide 13
  • Exemplo #include int main(){ int a; //Declarao de varivel printf(Digite um nmero:\n); scanf(%d,&a); if (a > 10) { //no vai ; if (a < 20) { //no vai ; if ((a % 2) == 0) { //no vai ; printf(O numero maior que 10, menor que 20 e par\n); } else{ printf(O numero maior que 10, menor que 20 mas no par\n); } else{ printf(O numero maior que 10, mas maior que 20\n); } printf(Fim\n); }
  • Slide 14
  • Estrutura de Seleo Estrutura de mltipla escolha escolha (X) caso E1: /*bloco de comandos*/ caso E2: /*bloco de comandos*/ caso E3: /*bloco de comandos*/ caso Contrrio: //pode ser omitido /*bloco de comandos*/ fim_escolha; switch (X) { case E1: /*bloco de comandos*/ break; case E2: /*bloco de comandos*/ break; case E3: /*bloco de comandos*/ break; default: //pode ser omitido /*bloco de comandos*/ break; }
  • Slide 15
  • Exemplo #include int main(){ char escolha; //Declarao de varivel printf(Menu:\n); printf(A - Arquivo\n); printf(E - Editar\n); printf(S - Sair\n); printf(Digite sua opo:); scanf(%c,&escolha); switch(escolha){ case A: printf(Abrindo arquivo...\n); break; case E: printf(Abrindo edio...\n); break; case S: printf(Saindo...\n); break; default : printf(Opo Invlida\n); break; } printf(Fim\n); }
  • Slide 16
  • Exerccios 1) Fazer um programa para ler um nmero e imprimir uma mensagem informando se ele positivo, negativo ou igual a zero. 2) Refaa o programa para calcular as raizes de uma equao do segundo grau atravs da frmula de Bscara, dando respostas diferentes para os casos: delta menor que zero, igual ao zero ou maior que zero. 3) Um cdigo est correto se for maior que 119, ou menor e igual a 46. Escrever um programa em C que teste este valor e some 1 no cdigo se ele estiver errado. 4)Ler um nmero de 1 a 7 indicando o dia da semana.O programa deve imprimir o dia em extenso e uma mensagem dizendo se dia til ou final de semana. Por exemplo, se for digitado 1, o programa imprime: Domingo - final de semana. Se for digitado 2, o programa imprime: Segunda - dia til e assim por diante.
  • Slide 17
  • Exerccios 5) Escreva um programa que receba um nmero e responda se par ou impar. 6) Dados 3 valores X, Y, Z verificar se eles podem ser os comprimentos dos lados de um tringulo e, se forem, verificar se tringulo equiltero, issceles ou escaleno. Propriedades - o comprimento de cada lado de um tringulo menor do que a soma dos outros 2 lados Equiltero - 3 lados iguais Issceles - 2 lados iguais Escaleno - 3 lados diferentes 7) Faa um programa em C que receba 3 nmeros inteiros digitados pelo usurio e os mostre de forma ordenada na tela.

Recommended

View more >