Excel - Usando a função PROCV

Download Excel - Usando a função PROCV

Post on 28-Jun-2015

640 views

Category:

Education

4 download

Embed Size (px)

DESCRIPTION

Bem vindos! hora de aprender como trabalhar com a funo PROCV no Excel, mas de um jeito bem diferente. Arquivos utilizados no vdeo: Vdeo: http://youtu.be/qFcPSLh_zG0 Arquivo do Excel http://www.tomasvasquez.com.br/forum/download/file.php?id=2039 SE (Funo SE) http://office.microsoft.com/pt-br/excel-help/se-funcao-se-HA102752994.aspx NO.DISP (Funo NO.DISP) http://office.microsoft.com/pt-br/excel-help/nao-disp-funcao-nao-disp-HA102752925.aspx Acesse tambm BLOG http://www.tomasvasquez.com.br/blog/ FRUM http://www.tomasvasquez.com.br/forum/ CURSO ONLINE DE C# http://www.tomasvasquez.com.br/cursocsharp Aqui tambm! FACEBOOK https://www.facebook.com/tomasvaquezsites TWITTER https://twitter.com/tomamais GOOGLE+ https://plus.google.com/+TomasvasquezBr/ Roteiro, apresentao, edio, etc, etc eu mesmo :)

TRANSCRIPT

  • 1. + Usando a funo PROCV

2. + O que preciso saber para usar (bem) a funo PROCV Requisitos Ao menos conhecer o Excel Usar frmulas bsicas Conceitos O que so tabelas Linhas - Dados Colunas MetaDados Conceito de Identidade Conceito de Registro 3. + Tabelas Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Mary 301 29 Conjunto de dados dispostos, na forma de linhas e colunas, dentro de clulas" Fonte: http://pt.wiktionary.org/wiki/tabela colunas linhas 4. + Linhas e Colunas Dados e MetaDados Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Mary 301 29 A Linhas contm os Dados As Colunas do significado aos Dados, ou MetaDados colunas linhas 5. + Conceito de Identidade Chave primria (cada valor nico) Registro (todas as informaes que compe um entidade, ou seja, todos os dados da linha) Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Mary 301 29 Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Henry 301 29 6. + Conceito de Identidade Chave primria (cada valor nico) Registro (todas as informaes que compe uma entidade, ou seja, todos os dados da linha) Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Mary 301 29 Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Henry 301 29 7. + A funo PROCV (VLOOKUP) Procura Vertical (linhas) Procura o valor informado em uma lista para poder retornar o mesmo dado e outros relacionados ao mesmo Link oficial: http://office.microsoft.com/pt-br/excel-help/procv- HP005209335.aspx 8. + A funo PROCV Sintaxe PROCV(valor_procurado;matriz_tabela;nm_ndice_coluna ;procurar_intervalo) Valor_procurado - Quem estou procurando na tabela Matriz_tabela - A tabela onde esto e onde vou procurar os dados nm_ndice_coluna - Qual dado do registro estou quero ver (coluna) Procurar_intervalo (No aplicvel para textos) 9. + PROCV funcionando Valor Procurado =PROCV(DI-328 ; A2:D6 ; 2 ; FALSO) Identificao Item Custo Marcao ST-340 Carrinho de beb US$ 145,67 30% BI-567 Babador US$ 3,56 40% DI-328 Fraldas US$ 21,45 35% WI-989 Lenos umedecidos US$ 5,12 40% AS-469 Aspirador U$ 2,56 45% Valor Procurado: DI-328 Sempre na primeira coluna 10. + A B C D 1 2 3 4 5 6 PROCV funcionando Matriz Tabela =PROCV(DI-328 ; A2:D6 ; 2 ; FALSO) Identificao Item Custo Marcao ST-340 Carrinho de beb US$ 145,67 30% BI-567 Babador US$ 3,56 40% DI-328 Fraldas US$ 21,45 35% WI-989 Lenos umedecidos US$ 5,12 40% AS-469 Aspirador U$ 2,56 45% Matriz Tabela: A2:D6 11. + PROCV funcionando Passo a passo =PROCV(DI-328 ; A2:D6 ; 2 ; FALSO) Identificao Item Custo Marcao ST-340 Carrinho de beb US$ 145,67 30% BI-567 Babador US$ 3,56 40% DI-328 Fraldas US$ 21,45 35% WI-989 Lenos umedecidos US$ 5,12 40% AS-469 Aspirador U$ 2,56 45% Passo 1 Procurar o valor (na primeira coluna) Passo 2 Ao encontrar, identifica a linha do registro 12. + 1 2 3 4 PROCV funcionando Passo a passo =PROCV(DI-328 ; A2:D6 ; 2 ; FALSO) Identificao Item Custo Marcao ST-340 Carrinho de beb US$ 145,67 30% BI-567 Babador US$ 3,56 40% DI-328 Fraldas US$ 21,45 35% WI-989 Lenos umedecidos US$ 5,12 40% AS-469 Aspirador U$ 2,56 45% Passo 3 Vai at a coluna informada Passo 4 Retorna o valor encontrado 13. + PROCV funcionando Resultado =PROCV(DI-328 ; A2:D6 ; 2 ; FALSO) Identificao Item Custo Marcao ST-340 Carrinho de beb US$ 145,67 30% BI-567 Babador US$ 3,56 40% DI-328 Fraldas US$ 21,45 35% WI-989 Lenos umedecidos US$ 5,12 40% AS-469 Aspirador U$ 2,56 45% Fraldas 14. + Nem tudo perfeito preciso tratar valores no encontrados (#N/D) Ex: =SE(.NO.DISP(PROCV(TV-123,A2:D6,2,FALSO)) = VERDADEIRO, "Funcionrio no encontrado", PROCV(TV- 123,A2:D6,2,FALSO)) S a primeira coluna da esquerda pode ser a identificao No contorna valores repetidos 15. + ENTO VERTICAL PROCV HORIZONTAL PROCH! ENTO VERTICAL PROCV HORIZONTAL PROCV e PROCH ?!?!? 16. + Finito! E isso. Agora com vocs!